Jump to content

Sanimarin troubleshoot


Featured Posts

Hi. New today to my Live aboard 57ft Narrowboat. Thought I would give her a treat tonight and pump out. Another boater advised to feed the toilet with clean water until the pump out was clear. However I used the empty pan button on the SFA and just as the pump out was looking good the empty stopped working. Can't get any reaction from the buttons anymore. The fuse is still ok. Any ideas would be welcomed

Link to comment
Share on other sites

9 hours ago, Phil. said:

The pumps are not meant to be used repeatedly in a short time frame, you may have over used it, and it needs to rest a while, provided it's not been damaged.

Thanks Phil. No fuse link inside the workings then? Couldnt find anything in the instruction leaflet!

SFA is the brand name of 35 48 and elite Sanimarin.

 

Link to comment
Share on other sites

11 hours ago, Kelpies boatman said:

Hi. New today to my Live aboard 57ft Narrowboat. Thought I would give her a treat tonight and pump out. Another boater advised to feed the toilet with clean water until the pump out was clear. However I used the empty pan button on the SFA and just as the pump out was looking good the empty stopped working. Can't get any reaction from the buttons anymore. The fuse is still ok. Any ideas would be welcomed

As mentioned by another poster they have a cut out if being abused!! it should re set and work quite quickly unless you have realy pissed it off that is. I have one of the daft things fitted on his boat, skip it and fit a proper boat bog.

Link to comment
Share on other sites

11 hours ago, Phil. said:

The pumps are not meant to be used repeatedly in a short time frame, you may have over used it, and it needs to rest a while, provided it's not been damaged.

Thanks Phil. No fuse link inside the workings then? Couldnt find anything in the instruction leaflet!

SFA is the brand name of 35 48 and elite Sanimarin.

 

Thanks all. I think I might have really pissed it off. So think I will have to resort to professional help

Link to comment
Share on other sites

4 minutes ago, Kelpies boatman said:

Thanks Phil. No fuse link inside the workings then? Couldnt find anything in the instruction leaflet!

SFA is the brand name of 35 48 and elite Sanimarin.

 

Thanks all. I think I might have really pissed it off. So think I will have to resort to professional help

Any bog standard boatyard should be able to sort it.!

  • Haha 1
Link to comment
Share on other sites

We had intermittent problems with ours for a while and then it stopped altogether. I phoned saniflo and spoke to an engineer. He said that they draw a huge current on startup and if the connection is old and maybe oxidised so that the large current doesn't appear, they just stop working. I cut out the old connection at the toilet end of the cable run and remade it and it's been fine ever since. Famous last words!

Link to comment
Share on other sites

Thanks for this. Had to do the same due to wrong sized wiring - Only 4mm used instead of 8mm recommended. Fortunately only had to renew the connection and not all the wiring! Working fine again. BTW Sanimarin providers Lee Sanitation VERY helpful(Fenny Compton Warks) 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.