Jump to content

Blazeaway

Member
  • Posts

    173
  • Joined

  • Last visited

1 Follower

Profile Information

  • Gender
    Male
  • Location
    warwick

Previous Fields

  • Occupation
    pro photograper
  • Boat Name
    Pooh Sticks
  • Boat Location
    napton

Recent Profile Visitors

2066 profile views

Blazeaway's Achievements

5

Reputation

  1. Might be worth considering for later in the year thanks. Right now though I just want to keep the MX60 going till the end of winter.
  2. I have an MX60 thats going well at the moment but on start up its started to become quite noisy, I think its the water pump. According to the manual this comes on immediately you switch the heater on My intention is to replace the whole unit (it is 16 years old now) with something new in summer 2021 but as we are in the depths of winter I really dont want to tackle that at the moment. Does anyone have an old MX60 or MX40 they would like to sell, really only need the main unit as I think, hope, the controller etc will last.
  3. thank you both for those posts, very helpful. I will give Ed a call, have spoken to him some years ago I believe, very helpful then. Thanks again
  4. Wise words thanks. I was intending to buy from MV Heating. Any other known stockists out there ?
  5. Hi Folks My Mikuni MX60 is running well and keeping us toastie warm, which is great. The only 2 issues I have are 1. The burning isn't as clean as I'd like, the exhaust is smokey most of time, for example on coming back to the boat in the dark you can see and smell lots of diesel smoke in torch light. 2. The exhaust noise is loud Regarding 1. (smokey burning) I have given the unit a good intrenal cleaning but thats made no difference. I suspect the wicks are next thing I need to replace to see if that helps. Firstly is that a sensible conclusion ? Also if I go down that route what else should i be doing whilst I am at it ? What parts should I be buying other than wicks A and B (533668 and 533669) ? Regarding 2 Noisy exhaust I don't appear to have an exhaust silencer (muffler). I huess that would be the first thing to fit. On checking for the part 533598A I can't find that exact part, however MV Heating list a 22mm and a 24mm muffler, will either of these fit the MX60 ? Best regards Frank
  6. As I am in lock-down you start to think daft thoughts and this came to me today whilst clearing the condensation this morning. We have one of those Karcher window vacuum cleaners and after sucking about 200 mls of water off the wondows I thought this, in theory at least, is distilled water so should be good enough as emergency battery top up should I not be able to get out before needing some. So collective wise ones, what do you think ?
  7. Thank you to you all. Really useful info. I will start off with giving them a soak in "plus gas" then try getting them out with appropriate quality bits. If thats a no go then go for the extractor or drill out and finally will refit with stainless screws.
  8. Nice, like that idea, how do you get the drill started dead centre to prevent the bit wandering off ? That also looks a good option but maybe more time consuming and risk of damage to the window frame with slippage of the cutting disk. Did you cause any damage on yours ?
  9. I have a small leak around one of my windows and am planning on taking the whole window out to reseal it. Looking at the screws they could well be a bit of bu%%er to get out. I guess that as these windows are quite common others may have encountered issues when taking them out. Any hints and tips gratefully recieved.
  10. Its in my engine bay and I must have caught it on clothing while getting out of there. In doing so the connector got snagged and opened up a bit so making it loose. So it looked like it was in place but it wasnt connecting.
  11. Now sorted....dodgy connection on a thermocouple, the one telling control unit water is hot. Found it loose so re-crimped the terminal and its all working perfectly again.
  12. My MX60 has been running great for last couple of years, I clean and service it once a year. Recently it has started to run a bit below par. After the start up phase the fan/motor runs a lot slower and never runs as fast as it used to do In the past it would run great and heat the hot water tank and radiators just fine. Now it still runs but seems to be running slower than in the past and the radiators and take longer to heat up and never get to full temperature. Have removed the burner end cover and cleaned everything and also cleaned the flame detector. Are there any typical issues that are likely to cause this problem or any ideas what I should be looking at more closely to get it back running 100% ?
  13. I give up with some folk. I am concerned for the situation that crt has put me and others in. You carry on believing that this stuff doesnt matter. Your view points are so ill judged. I am sure nothing bad will ever happen if you stick your head in the sand. I will not be updating this thread anymore with what I learn.
  14. Direct from the person who owns one of the boats in question
  15. Well looks like its possible someone is trying to use the data for criminal gain Just learnt that crt have been notified that several boats have been "sold" and requested changes of ownership sent into crt. So its not all just a storm in tea cup who knows what else they will come up with. The data breach includes boat name number and location of home mooring. For example If they are successful in reassigning ownership just turn up nick it sell it and rightful owner will not be aware until they discover it gone.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.