Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

Heather

Member
  • Content Count

    19
  • Joined

  • Last visited

Everything posted by Heather

  1. My friend works in a car garage hopefully has right stuff. The oil pressure was only 25 when engine first fitted 2 years ago and they had to clean the oil pressure switch as sticking. It drops from 50 to 25 quite often. My old bmc engine always stayed at 50. Probabky more rubbish they have told us!
  2. It was Stephanie we paid they own key diesels now. Complete nightmare!
  3. Yes it was key diesels. They said they would put another engine in buy it would cost another £1500 on top of what we have paid. We have had 55 visits from them and still dont have a working engine! We have threatened legsl action several times and they don't seem bothered. How can a disgraceful company like this still keep running!
  4. Yes it was the two washers at the top.I will see of I can get someone to do a compression test etc and let you know. It may take a week but I will let you know. Does this post get closed if you don't write on It for a week? Thanks
  5. Sorry for late reply I locked out my password. Not very goid at this! After manual pump adjust boat ran and started lovely up to 1600 revs above this it overheated. We overtook a boat and that was the bang and drop in oil pressure. The came out and said fine just gasket on the pump or injector so we kept topping up oil and came home slowly from Wallingford to Broxbourne. Temp guage stopped working so we just went slow. On starting in morning clouds of smoke and very rattling and noisy but settled down after a while. They said they would replace engine under guarantee. When they took engine out they said it was our gearbox rattling and that the engine made different noise when put in gear on bench. After months of arguing they returned engine and installed it. It work for 2 short runs at low speeds. When we tested faster that is when the oil came out from the oil pressure pipe coming off. Our friend put it back on and said brass washers too big so fuel leaking fom on top of filter. They changed these and said fuel is getting through ok. It now loses revs and cuts out. The starting was ok but since the oil came out is now hard and engine noisy when cold. We are waiting for someone to help us try the things you guys have kindly suggested but he is away this weekend. The idle damper is I think what rcr called the anti stall. Our friend tried adjusting this but didn't seem to do much so put back as it was. Really frustrating. I really appreciate the help you guys are giving. The injectors were fitted by the before they reinstalled the engine despite the fact they said their engine was fine!
  6. thank you for the manual. I could not see where the idle adjustment was in there though. I will see if i can get someone to do this for me. The pump was set by ear by RCR when the boat wouldn't start on our way up the Thames last year and it ran lovely until we broke down. This was before the engine came out after it went bang and lost oil pressure and started smoking but it got us home. They said this was just the leaking injector pump as gasket had failed and blamed our gearbox. Don't know why they changed the injectors as they said their engine was fine! I presume the timing would be different with new injectors.
  7. The gearbox is a velvet drive. The rattle goes with more revs. RCR said they put a new drive plate on but they have said this before and we found out differently. The revs are 15 on dial has always gone to just under 21 revs with no trouble in past.
  8. Thank you all so much for being patient with me, I have taken some photos but not sure how to get them from my phone to here. I tried to check the gearbox oil which involves taking the steps and floor of boat but then it i couldn't undo it as i don't have a big enough spanner. I will get my husband to have a go with some pliers next time i up to the boat. The gearbox was rattling when the boat was on the bench being tested by RCR. They said it was a gearbox fault that was causing the overheating. The gearbox works fine. A gearbox repairer looked at it on their bench and said it had a slight drag in neutral. I will recheck the prop but when the engine was installed you could turn it by hand. When the engine was first installed 2 years ago (yes this has been going on that long!) i queried the rattle from the gearbox with the installer who said it was a worn drive plate and to let RCR know in case it fails. They said it was new but the gearbox did not do rattle on the old engine. The leak was not gearbox oil as this is red as we had this happen in the past. I need to see what i can try then get my friends to help me try these things. They have looked and run out of ideas.
  9. Could this be a gearbox fault as there is a rattle when it goes in gear? The prop is fine.
  10. Thank you. The oil level is ok. I don't think there is any air in the system as it normally revs up before dying if it has air and i had a friend look who said it seems ok. I am baffled as to why the revs wont go over 1500 when in gear as they go to 2100 when in neutral.
  11. She does weigh nearly 8 tonnes. We have towed before but a nightmare.
  12. Someone checked that the fuel is getting through ok so not looking good for the pistons! Would the engine still sound so sweet if the pistons were no good? It does sound rattly and noisy for first 5 minutes?
  13. It was definitely the oil pipe. I said they were useless! WE had someone interested in buying the boat as well! t is a 30 ft broom skipper so too heavy to tow far.
  14. I also forgot to mention that after temperature got up to 95 degrees the water level had not gone down when we took the header cap off! The revs wont go over 1500 now used to go to 2100. Any idea what this means? I will try the London Facebook to see if they know of any engineers. Thanks
  15. Sorry i was busy last night and not sure if i am even answering these properly. We are in Broxbourne on the river lea. All the local engineers are useless and booked up for months. This is why we had RCR install a new engine 2 years ago as we had bad starting and cutting out and the engineers did not sort it. After 2 years we have only used the boat last year on our limp home Thames trip. Their engineers are terrible and they used old parts most of which they replaced eventually so nearly all new or refurbished parts now and still wont work. The engine is now out of guarantee and they wont come out. How much is a boat worth without a working engine! I will go up later and try to get some photos Thanks for your help
  16. We didn't know oil coming out til we stopped just saw oil pressure dropping. The engine is noisy for 5 minutes when starting then sounds sweet when warmed up a little. Once the engine has started for the first time it starts easily until we have done it 10 times then it starts to overheat. We had the prop checked and is also clear. I think it was the fuel pump that was leaking. The pipe that came off had a metal core that had frayed and was just pushed on. This caused the oil to come out. We had trouble starting before and an engineer adjusted the timing on the fuel pump? It ran lovely afterwards apart from overheating. We went down the Thames keeping revs below 1600 and it was fine until we went faster then there was a bang and we lost oil pressure. We had an engineer who said injector pump seal had gone so it was losing oil. We limped home with poor starting and smoke poring out on starting in the mornings. This was why the engine was removed again. Since it has been back the overheating seemed ok on 2 short trips it was only after the oil came out that the cutting out started. We can only do basic things ourselves and keep asking friend to help as we cant find an engineer in the Broxbourne area to help so don't think we can start removing injectors. We are waiting for someone to help check the impeller as we don't know how to do it. It was new last September. It has a header tank and a water strainer. We have checked the strainer and put a rod down the pipe near the stopcock. Both are clear and there is plenty of water coming bubbling up and coming out the exhaust.
  17. Sorry not oil cooler oil pressure pipe. The oil was brown/black it all came out. We only drove for 5 minutes to get home. Since the engine was reinstalled it smokes black a little on start up. The starting is also very poor now. It looks like black soot is coming out the exhaust with the water. The engine was in boat before but kept overheating and the injector/fuel pump was leaking so went back and had new injectors fitted. They said we had a rattle on the gearbox and it was our gearbox causing the overheating but we had the gearbox reconditioned the year before. It did not overheat the first 2 times we used it but kept cutting out. After we went at full throttle all these problems started. They installers wont come back out now and we cant find a good engineer in our area. We had an electric fuel pump fitted last year and had the fuel polished as well. It does not rev up before stalling. Where is the fuel tank breather? Thanks
  18. Sorry not oil cooler oil pressure pipe. The oil was brown/black it all came out. We only drove for 5 minutes to get home. Since the engine was reinstalled it smokes black a little on start up. The starting is also very poor now. It looks like black soot is coming out the exhaust with the water. The engine was in boat before but kept overheating and the injector/fuel pump was leaking so went back and had new injectors fitted. They said we had a rattle on the gearbox and it was our gearbox causing the overheating but we had the gearbox reconditioned the year before. It did not overheat the first 2 times we used it but kept cutting out. After we went at full throttle all these problems started. They installers wont come back out now and we cant find a good engineer in our area. We had an electric fuel pump fitted last year and had the fuel polished as well. It does not rev up before stalling. Where is the fuel tank breather? Thanks
  19. I had a reconditioned engine fitted. It worked fine until the oil cooler pipe came off and all the oil came out. We replaced the pipe and filled up the oil. Now it runs ok on tickover but cuts out after 5 minutes when using. It restarts but cuts out again and after a few goes like this the temperature goes up and it does not restart for a while. We had to replace the washers on the fuel filter as leaking and the fuel is flowing through ok.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.