Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

Featured Posts

3 minutes ago, blackrose said:

After 12 years of being dry mine started leaking. I took the hatch off and found a bit of rust underneath which was collecting water. I also cut a 45 degree slot just in front of the hatch on each runner with a hacksaw. I actually cut a 5mm slot from each brass runner. No more drips now. 

Thanks blackrose, that sounds like what I need to do.

Share this post


Link to post
Share on other sites
11 hours ago, blackrose said:

After 12 years of being dry mine started leaking. I took the hatch off and found a bit of rust underneath which was collecting water. I also cut a 45 degree slot just in front of the hatch on each runner with a hacksaw. I actually cut a 5mm slot from each brass runner. No more drips now. 

Blackrose did you actually cut right through the brass slider and is 5mm the depth or width of the slot? Thanks.

Share this post


Link to post
Share on other sites
19 hours ago, Traveller said:

Blackrose did you actually cut right through the brass slider and is 5mm the depth or width of the slot? Thanks.

I cut right through the brass runner and then took the piece out with a screwdriver. I painted over the steel underneath with some primer. Make sure you cut the slot at 45 degrees otherwise your hatch won't slide! 5mm is the width, it may have been slightly wider. The brass strip itself is only about 2 or 3mm deep. 

While you're at it turn the hatch cover over and check for rust at the contact points. Rub it down if it's rusty. I'm actually going to stick a small strip of brass onto that point with stixall to stop the rust returning. 

Edited by blackrose

Share this post


Link to post
Share on other sites

Thanks, that is the plan then. What I have noticed is the previous owner has inserted a wood panel (roses and castle stuff) into the hatch and it appears to be fixed by having it rest/wedged between hatch and slide. That looks like potential trouble to me!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.