Jump to content

Alternator over charging


buggsy
 Share

Featured Posts

Hi,

can anyone help with some advice?

I have a 70 amp A127 alternator with 4 x 110 amp wet leisure batteries that are only 1 month old. The alternator is only 18 months old and I have an Adverc system fitted. All was ok but I have noticed in the last couple of weeks the green (Adverc warning light) blinking. I have also an ADVERC DCM (volt meter) fitted and this weekend i have seen the charging voltage rise to 15.5 volts! I thought i could be the Adverc but once I disconnected this the voltage went even higher to 16 volts!!

Could it be the alternator regulator? I thought the Adverc was designed to prevent overcharging. As usual any advice gratefully received.

 

Forgot to add i have also noticed the charge light is faintly lit as is the green adverc light when not blinking.

 

Thanks,

 

Steve

Edited by buggsy
Link to comment
Share on other sites

Hi,

can anyone help with some advice?

I have a 70 amp A127 alternator with 4 x 110 amp wet leisure batteries that are only 1 month old. The alternator is only 18 months old and I have an Adverc system fitted. All was ok but I have noticed in the last couple of weeks the green (Adverc warning light) blinking. I have also an ADVERC DCM (volt meter) fitted and this weekend i have seen the charging voltage rise to 15.5 volts! I thought i could be the Adverc but once I disconnected this the voltage went even higher to 16 volts!!

Could it be the alternator regulator? I thought the Adverc was designed to prevent overcharging. As usual any advice gratefully received.

 

Forgot to add i have also noticed the charge light is faintly lit as is the green adverc light when not blinking.

 

Thanks,

 

Steve

I would try a new regulator about 7 squid, but the adverc bypasses the reg indicating a failure possibly elswhwere.

 

If it was me I would get a second hand A127 off ebay and substitute and work from there. As your alt is only 18m old just check that the rotation has had the fan cooling as intended as they still work in both directions but one will shorten alt life

Edited by blodger
Link to comment
Share on other sites

I would try a new regulator about 7 squid, but the adverc bypasses the reg indicating a failure possibly elswhwere.

 

If it was me I would get a second hand A127 off ebay and substitute and work from there

 

 

I would not because excess charging volatge on a machine sensed alternator can be caused by a blown diode. Usually one of the F or Aux diodes that put the warning lamp out and then provide the voltage to the voltage regulator. This is all but certain if the warning lamp glows.

 

With a blow F diode the output on the D terminal will be low (hence the glowing warning lamp) and it is that low volatge that the voltage regulator see despite the correct volatge being on the B+ terminal. The result is that the regulator increases the output voltage to what it (incorrectly) thinks is correct with excess voltage on the B+ terminal - hence the Adverc showing high volatge.

 

Put a multimeter set to 20V DC (200 VDC for a 24 volt system) between D and B+ (warning lamp terminal and main output terminal) and rev the engine. If it reads more than about a volt you have a diode blown or possibly a poor solder joint inside the alternator.

 

(Test attributed to Sir N I think).

Link to comment
Share on other sites

Thanks Blodger and Tony for your replies i will test the diodes tomorrow and probably have to take the alternator back to the company that replace it 18 months ago.

 

cheers,

 

Steve

Link to comment
Share on other sites

Thanks Blodger and Tony for your replies i will test the diodes tomorrow and probably have to take the alternator back to the company that replace it 18 months ago.

 

cheers,

 

Steve

It will be worth trying to work out the why it has failed after finding out the what has.

 

A for example, do you have a dodgy 1 to 2 changeover/isolator switch or can you recall instances where you have inadvertently disconnected the alternator from the battery when it was running?

Link to comment
Share on other sites

The Adverc doesn't bypass the internal regulator, it just adds to it, so if the internal regulator winds up the voltage the Adverc won't try to stop it.

The OP had a higher voltage when the Adverc was disconnected. I would have chanced another reg but it is easy to do the Sir Nib/Tony B diode test as Smelly has (to find out alt itself was OK diff 0.05v between D+ and B for the latter)

Link to comment
Share on other sites

Quick update.

 

Alternator refitted and all charging ok with Adverc cycling as expected. I will monitor this closely to see how long it lasts. The regulator i know was new as i purchased it and i have to assume the rectifier was new when the alternator was refurbed 18 months ago. Is this normal life span?

 

cheers,

 

Steve

Link to comment
Share on other sites

Quick update.

 

Alternator refitted and all charging ok with Adverc cycling as expected. I will monitor this closely to see how long it lasts. The regulator i know was new as i purchased it and i have to assume the rectifier was new when the alternator was refurbed 18 months ago. Is this normal life span?

 

cheers,

 

Steve

 

 

No, normally if they last a month or so they will last years.

 

If there was not a poor solder joint inside the alternator I would want to be sure it is adequately cooled. Problems occour when people box in an engine and do not leave adequate ventilation apertures, if the alternator fan is the wrong hand, or if the alternator develops a high output at low rotational speed because of the wrong pulley ratio.

Link to comment
Share on other sites

No, normally if they last a month or so they will last years.

 

If there was not a poor solder joint inside the alternator I would want to be sure it is adequately cooled. Problems occour when people box in an engine and do not leave adequate ventilation apertures, if the alternator fan is the wrong hand, or if the alternator develops a high output at low rotational speed because of the wrong pulley ratio.

 

... or if the dogs shed so much hair that the alternator cooling slots get blocked (ask Molly and Telford how I know this).

 

Our original (motorola) alternator lasted for about 10 years, but when it was rebuilt it only lasted for 3 years and then each subsequent rebuild lasted for about half as long as the last. When it was down to lasting for just a couple of months we bought a new one - which lasted for 2 years. I've rebuilt that one myself, it will be interesting to see how long it lasts for.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.