Jump to content

Balmar ARS-5 programming weirdness


cheesegas
 Share

Featured Posts

HI all, everyone's been so helpful in solving past problems, hopefully someone here familiar with Balmar regulators can help. Thanks in advance

 

I've got a Balmar ARS-5 external alternator regulator here which I'd like to use with my lifepo4 build. Yep, I'm aware that it's not got a lithium specific program but after looking at the manual, it's possible to set it up so it's suitable.

 

Anyway, I've got it connected up to a 13v supply (manual says it must be over 12.5v) to program in the comfort of being inside and not in the engine bay... Black to ground, red and brown to positive. It powers up fine and goes through the menu system fine too.

 

However, there's a few oddities. I've attached the relevant pages of both versions of the manual I've found, which seems to refer to pre 2017 and post 2017. I have an October 2009 model with software revision 1.9. The manuals mention revision 3.8.

 

From the advanced programming menu, the AHL (high voltage limit) and ALL (low voltage limit) are missing - it simply jumps straight from the option before it to the option after. Also, the pre 2017 manual refers to these settings as high and low voltage alarms and post 2017 refers to them as limits. 

 

It's also impossible to change the float voltage to below 13.7. I can get it up to 14.2 and then back down again, but not below 13.7. Note that the flooded program preset has a default float voltage of 13.4, if I try and change it up or down by 0.1v, it jumps straight to 13.7 and then can't be changed to anything lower.

The manual says that the allowable float voltage range is between ALL (which isn't present in the menu) and the absorption voltage (set to 14.2). 

 

Any idea why it's doing this? It's almost like the ALL option is set to 13.7 so the float voltage can't be set any lower than that. However, the option is missing from the menu. Or, a manual for revision1.9 would be great.

 

I've reset it to factory defaults by pressing and holding on the SAV screen, and also tried raising the supply voltage to 14v.

Full manual - pre 2017.pdf Full manual - post 2017.pdf Pages - pre 2017.pdf Pages - post 2017.pdf

Link to comment
Share on other sites

Thanks. I've looked but I can't see a way to update the software on it - as it's encapsulated in potting compound, there's no JTAG etc points to communicate with it. Unless there's some Balmar specific computer interface which uses a few of the pins in a weird way...

 

I got it for almost free as I'm cheap and don't want to fork out for a Wakespeed or Balmar 614...would be nice it if works.

Link to comment
Share on other sites

14 minutes ago, hilandnick said:

Marine how to have some videos on programming balmar controllers.

 

https://marinehowto.com/programming-a-balmar-voltage-regulator/

Thanks, I’ve seen those. The issue here is that the operation of the unit doesn’t match the manual however, and there appears to be multiple hardware/software revisions and versions of the manual. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.