Jump to content

Another Alternator Thread


davidb
 Share

Featured Posts

I am sure one of our favourite topics is batteries and alternator, so I shall start another.

 

When my setup is running normally I start up the engine in the morning when the voltage gets down to around 12.0 across the batteries - 4  Trojan T - 6620s wired in series/parallel. A clamp meter on the return cable to the bank soon starts reading about 25 amps, and an hour's charging at about 14.4 volts at that rate gets it up nicely before the day which often involves another a few hours cruising, so they are always well above 20 and have never been low on water.

.trojan.jpg.3eb1e4148bc1e0e64764fa88411047ff.jpg

 

.

I think the Alternator is a Lucas and it is wired through a split charge diode, below

 

Isol.jpg.5785922d4d29d46cf924d8e78d5b0c5f.jpgIsolator.jpg.71bc9b07d6425e80d61a41fc85465eb4.jpg

 

.

Yesterday the alternator failed so I took it out and replaced it with a spare I keep on board, but this has not got the tapping for an Adverc booster, but I thought it might keep us going for a while till the original was repaired. But it isn't getting the battery over about 13.7 volts. When I tested the voltages on the Surepower Isolator, the input is at 14.3 or 14.4, but it is losing about 0.7 volts.  So I assume these isolators are not a lot of use for with a standard alternator? I shall report back when I get the new one fitted, firstly as standard, then with the Adverc attached.

Edited by davidb
added to
Link to comment
Share on other sites

20 minutes ago, davidb said:

When It tested the voltages on the Surepower Isolator, the input is at 14.3 or 14.4, but it is losing about .7 volts.  So assume these isolators are not a lot of use for a sandart alternator?

 

I have a pair of exactly the same "Shore Power Isolators' my measured voltage difference between the input and output is 0.8 volts.

I am using standard 14.6 volt regulated HC-Cargo Alternators

Link to comment
Share on other sites

On 12/10/2021 at 20:32, Tracy D'arth said:

All diodes "lose" 0.7 to 0.8 of a volt.  Better to have a Voltage Sensitive Relay or even just a split charge relay.

 

Its "easy" to put the extra connection in a Lucas or just about any make of alternator if you have any mechanical/electrical ability.

or even a SmartBank!

Link to comment
Share on other sites

Well above 20 - what?

 

Starting charging at 12v is probably a bit on the low side.

 

I would suggest you get the alternator to an  auto or marine electrician to have the extra cable fitted. I think the Adverc website has instructions for DIY fitting the wire on the more common alternators. You will never get the batteries properly charged until you:

 

get the wire fitted,

 

get a battery sensing alternator or maybe a battery sensing regulator is available for your alternator,

 

or get rid of the split charge diode and either fit a "zero volt drop" electronic version or a decent VSR and rewire.

 

  • Greenie 1
Link to comment
Share on other sites

16 hours ago, Tony Brooks said:

Well above 20 - what?

 

Starting charging at 12v is probably a bit on the low side.

 

above 20 Amps on the clamp meter.

 

I appreciate starting at 12v is low, but since my last post I have contacted the previous owner of the boat and it looks like the batteries could be 13 years old!  So next spring will probably see me looking for new Trojans or similar.

 

I have got a new alternator to fit now with the extra cable fitted, might be a week before I get it replaced, but I shall report back here.

 

Thanks for your replies.

Link to comment
Share on other sites

If you are stopping charging at 20 amps charge or higher, then you are destroying the batteries by sulphation. You need to go on charging until the current has stopped dropping over about an hour at 14.2volts plus or when the current has dropped to 1 to 2% of batery capacity, again at a voltage of 14.2V or higher

Link to comment
Share on other sites

8 hours ago, Tony Brooks said:

If you are stopping charging at 20 amps charge or higher, then you are destroying the batteries by sulphation. You need to go on charging until the current has stopped dropping over about an hour at 14.2volts plus or when the current has dropped to 1 to 2% of batery capacity, again at a voltage of 14.2V or higher

I'm getting confused, Do you mean that the charging current is 20A?  I think you must mean that and I would agree that it would be at far too low a soc...

 

I am no longer confused. I see exactly what you mean.  I just needed to allow my aging brain to catch up and finish processing. 🙂

 

N

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.