Jump to content

Alternator woes


Featured Posts

Hi all,my alternator is the lucas 127, 75 amp on a v belt configuration, but it is only putting out 13.4 volts,witch is not charging the batteries much,I have two leisure one starter, is there anyway I can beef up my charging rate two hours tv of an evening and the batteries are flat,I also have 300watts of solar,many thanks 

 

Link to comment
Share on other sites

To  amplify Tracy's questions. Although I would find 13.4 volts tending to indicate a phase or two failed in the alternator, you have to be aware that as the charging current increases the maximum voltage the alternator can produce falls, so the voltage reading in its own is NOT sufficient to diagnose the fault. We also need the charging current.

 

If your batteries are very flat or if they are shorting internally, then the may be allowing so much current to flow that 13.4 volts is acceptable. If so, the over the next couple of hours, flat batteries will allow the charging current to fall and consequently the voltage to rise. This will not happen with faulty batteries, but the batteries would be getting hot (possibly in just parts), be gassing well, and probably smell.

 

With 300 watts of solar at this time of year, I would suspect the batteries. If they are shorting, they will be discharging themselves in addition to whatever you may take out of them.

 

You need to find the cause of your inability to watch a couple of hours of TV each night, rather than add an alternator controller and so on. That may come later for winter charging.

 

Edited to add: How fast was the engine revving? If not at least 1200 rpm it could just be a speed issue.

Edited by Tony Brooks
Link to comment
Share on other sites

Things that you could do in order of cost :

1: stop watching Tele

2: get alternator checked and repaired if needed.

3: replace batteries.

 

Don't do 3 without doing 2

 

😁😱😎

 

Link to comment
Share on other sites

2 minutes ago, Loddon said:

Things that you could do in order of cost :

1: stop watching Tele

2: get alternator checked and repaired if needed.

3: replace batteries.

 

Don't do 3 without doing 2

 

😁😱😎

 

 

If he has a suitable ammeter, he can go a long way towards checking 2 without sending any money. Likewise with the ammeter reading, if it confirms the alternator is producing close to 70 amps and continued to do it over an hour, it would go a long way to condemning the batteries, especially if they were then hot and gassing.

Link to comment
Share on other sites

5 hours ago, dreadnought said:

Hi all,my alternator is the lucas 127, 75 amp on a v belt configuration, but it is only putting out 13.4 volts,witch is not charging the batteries much,I have two leisure one starter, is there anyway I can beef up my charging rate two hours tv of an evening and the batteries are flat,I also have 300watts of solar,many thanks 

 

It could be a number of things.  If it is the alternator it is possibly the regulator.  You can buy these on their own for not much.  On the other hand an A127 is relatively cheap too at around £60-70.00  If the Alternator is at fault I would just buy a new one.  Plenty to be found from many sources including eBay.

Link to comment
Share on other sites

I would like to  everyone for there response to my thread, I can add that I took a reading with my multimeter from the alternator and it was producing 14.6v,then a reading from the split charge relay and it showed only 13.6v,and also 13.6 at the batteries, 

Link to comment
Share on other sites

4 minutes ago, dreadnought said:

I would like to  everyone for there response to my thread, I can add that I took a reading with my multimeter from the alternator and it was producing 14.6v,then a reading from the split charge relay and it showed only 13.6v,and also 13.6 at the batteries, 

Would I be right in thinking the alternator feeds directly to the starter battery and then feeds the domestics via the split charge relay?

Link to comment
Share on other sites

Just now, ditchcrawler said:

Would I be right in thinking the alternator feeds directly to the starter battery and then feeds the domestics via the split charge relay?

 

Because if it does you stand a higher chance of burning the relay contacts so alternator to domestic bank and then the VSR feeding to the engine battery.

Link to comment
Share on other sites

6 minutes ago, ditchcrawler said:

Would I be right in thinking the alternator feeds directly to the starter battery and then feeds the domestics via the split charge relay?

No the alternator feeds straight to the relay then is distributed from there

Link to comment
Share on other sites

3 minutes ago, dreadnought said:

No the alternator feeds straight to the relay then is distributed from there

Is it a relay or a diode splitter?

Sounds like a diode splitter wired that way.

A picture would help.

 

Edited by Loddon
Link to comment
Share on other sites

2 minutes ago, Loddon said:

Is it a relay or a diode splitter?

Sounds like a diode splitter wired that way

 

And that would go a long way to explaining the voltage loss, but not all of it.

 

Photo of this device please

 

Edited to add - and alternator connections, this might be a battery sensed alternator with an extra terminal.

Edited by Tony Brooks
Link to comment
Share on other sites

4 minutes ago, dreadnought said:

Yes it's a diode

 

Then it really needs to go, unless it's one of the expensive electronic gizmos often sold as zero volt drop diodes. If it is, then it sounds as if it still needs to go because it's faulty.

Link to comment
Share on other sites

10 minutes ago, Tony Brooks said:

 

Then it really needs to go, unless it's one of the expensive electronic gizmos often sold as zero volt drop diodes. If it is, then it sounds as if it still needs to go because it's 

What do you recommend I should replace the diode with,tia

Link to comment
Share on other sites

Remove it and wire the alternator to the domestic batteries with a VSR to charge the starter battery. Look for a dual sense VSR as it makes wiring easier, if you cant get a dual sense one just wire it so the sense (normally from the starter battery) is on the domestics.

The one I linked to before  will do the job.

Edited by Loddon
Link to comment
Share on other sites

On 24/08/2021 at 12:50, Tony Brooks said:

You need to find the cause of your inability to watch a couple of hours of TV each night,

 

I think it might be helpful to find out what sort of telly it is, too.

 

I dunno what power consumption modern tellies draw nowadays but if it is a 56" widescreen monster, it could be quite a bit I suspect. 

 

 

Link to comment
Share on other sites

1 hour ago, dreadnought said:

What do you recommend I should replace the diode with,tia

 

What Loddon linked to, but it will require some rewiring of the charging cables but if you can mount it where the diode is you will probably find that you can use two of the wires and if you are not worried about helping others fault find and will accept a tiny volt drop you could probably use all three.

 

 

This is NOT a recommendation, but may save you some effort. Existing alternator cable AND the one going to the domestic bank on the domestic/sense nut terminal on the relay, The cable going to the engine on the other. Then a new thin wire from the last small terminal or fly lead to any negative - providing the engine and domestic battery negatives are linked, as one would expect.

25 minutes ago, MtB said:

 

I think it might be helpful to find out what sort of telly it is, too.

 

I dunno what power consumption modern tellies draw nowadays but if it is a 56" widescreen monster, it could be quite a bit I suspect. 

 

 

 

I agree, but suspect he now has, but what state his batteries are in are anyone's guess. I suspect they may be heavily sulphated, so now have minimal capacity.

Link to comment
Share on other sites

3 hours ago, Tony Brooks said:

I agree, but suspect he now has, but what state his batteries are in are anyone's guess. I suspect they may be heavily sulphated, so now have minimal capacity.

 

My first 12V boat telly was a B&W cathode ray tube jobby that drew about 4A while we were watching it. I'm guessing a modern, bigger colour TV draws much the same. So if the OP's telly kills the batts after 2 hours, they may well only have a capacity of about only 8AH, rather than the (probable) 200AH badge capacity. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.