Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

mike check

Member
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

Profile Information

  • Gender
    Male

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks for the suggestions. I went to test it again earlier. Checked the control lever was engaing on the cable. Seemed fine. Checked the prop. Was not fouled or loose. Then ran the engine with the weed hatch open...(no i did not sink). And it worked in both gears each time. Ran in in gear for half an hour and checked again. Forward and reverse. Almost annoying that it worked normally. I was moored up during this test so my new thinking is the prop getting jammed up easily when moving. Will take it for a propd spin at the weekend. Thanks
  2. So ive got a thornycroft t33 mitsubishi 2 cylinder and a hurth gearbox. ( The engine runs OK. but sometimes there is no power in the prop. Push it into gear and very little propulsion the prop shaft is spinning and no power (could prob move about 1/2 mile an hour on a good day with no stream). Pop it back into neutral then back into gear and the prop produces power. (However limited by the tiny engine but you know it moves). Was thinking its not the gearbox because the prop shaft is spinning either way. But the boats in the water and not coming out for a while so gear bix might be servicable but prop shaft and bearings etc not atm. Any thoughts appreciated...
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.